aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2009-11-19 13:25:42 -0800
committerBen Pfaff <blp@nicira.com>2009-11-23 11:34:54 -0800
commitd161c099279e9ab564636c72423268e6da69f795 (patch)
tree5bbbafe4b00a3461e8084f03324b98bf0600f596 /Makefile.am
parent83f6c0502c67ea117c73d3bbb91f9b9e0e81bf87 (diff)
Move C compiler warning (-W) flags from CFLAGS to AM_CFLAGS.
C compiler warning options added by the "configure" script have until now been put into CFLAGS. However that option is supposed to be reserved for the user under Automake rules, so move them to AM_CFLAGS. Besides increased adherence to Automake rules, this is useful because AM_CFLAGS can be overridden on a per-target (e.g. program or library) basis, whereas CFLAGS cannot. In turn, building the sFlow library (which will be added in an upcoming commit) requires overriding the compiler flags to avoid some warning messages. (By modifying the warning flags, we avoid the need to modify the sFlow library in any way.)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index add0e72a..de51e10f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,7 @@ AM_CPPFLAGS += -I $(top_srcdir)/include
AM_CPPFLAGS += -I $(top_srcdir)/lib
AM_CFLAGS = -Wstrict-prototypes
+AM_CFLAGS += $(WARNING_FLAGS)
if NDEBUG
AM_CPPFLAGS += -DNDEBUG