aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Wright <chrisw@sous-sol.org>2011-12-08 23:36:03 -0800
committerBen Pfaff <blp@nicira.com>2011-12-09 09:42:34 -0800
commit9fed3d3e966f2ae3bb56d454f1b6fa41edb3c247 (patch)
tree964ced7ce69e4b62f64bc9ba66300f6a8e07fd85 /Makefile.am
parenta038fa773089b33332bd4d860b9bd4190e0cc573 (diff)
man: fix pic issue at the source
The commit 0993b66 (man: pic failed to run during manpage-check) worked around the manpage-check warning generated by groff. Using "-T ascii" rather "-T utf8" was enough to silence the warning because the man page has this condition in it: .if !'\*[.T]'ascii' However, rpmlint generates the same warning as manpage-check was (it uses -Tutf8), and manpages are generated using -Tutf8 (leading to an fairly unreadable drawing). So let's change the logic a bit and allow pdf generation w/ nice drawing and kill it for tty's. Cc: Ethan Jackson <ethan@nicira.com> Signed-off-by: Chris Wright <chrisw@sous-sol.org> Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c0a7ade5..51441cee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -157,7 +157,7 @@ ALL_LOCAL += manpage-check
manpage-check: $(man_MANS) $(dist_man_MANS) $(noinst_man_MANS)
@error=false; \
for manpage in $?; do \
- LANG=en_US.UTF-8 groff -w mac -w delim -w escape -w input -w missing -w tab -T ascii -man -p -z $$manpage >$@.tmp 2>&1; \
+ LANG=en_US.UTF-8 groff -w mac -w delim -w escape -w input -w missing -w tab -T utf8 -man -p -z $$manpage >$@.tmp 2>&1; \
if grep warning: $@.tmp; then error=:; fi; \
rm -f $@.tmp; \
done; \