aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-05-26 16:15:48 -0700
committerBen Pfaff <blp@nicira.com>2010-06-09 09:13:11 -0700
commit9741af797d62aec4cc55d231c093c61e201c8ebe (patch)
treea28784ddced3cd331bd85e8ae9e026867a3959dd /Makefile.am
parentc73814a3e6cbdf8c4083ef1d510377e41cb82f6a (diff)
Fix EXTRA_DIST dependence on Automake conditionals.
Automake respects conditionals around EXTRA_DIST assignments. That is, if COND is not true, then the following will not distribute 'myfile': if COND EXTRA_DIST += myfile endif See http://article.gmane.org/gmane.comp.sysutils.automake.general/10891 for more information. This behavior is surprising, at least to me. But we can work around it: anything that can ever *potentially* be assigned to noinst_HEADERS is always distributed. So this commit eliminates the problem by adding $(EXTRA_DIST) to noinst_HEADERS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c902e41d..fa7b5ea2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,12 @@ noinst_SCRIPTS =
OVSIDL_BUILT =
SUFFIXES =
+# This ensures that files added to EXTRA_DIST are always distributed,
+# even if they are inside an Automake if...endif conditional block that is
+# disabled by some particular "configure" run. For more information, see:
+# http://article.gmane.org/gmane.comp.sysutils.automake.general/10891
+noinst_HEADERS += $(EXTRA_DIST)
+
EXTRA_DIST += \
build-aux/update-debian-changelog \
soexpand.pl