aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-08-25 11:15:27 -0700
committerBen Pfaff <blp@nicira.com>2011-10-26 15:50:50 -0700
commit94512c4abe1062ad18cb32fbf1f4947fda06a9cd (patch)
tree51dcef8fdf6012db5695a31b9db28ddda64b822c /Makefile.am
parent06b592bcbe2e5a435589b0ce3d77530756c20572 (diff)
Move soexpand.pl into build-aux and make it non-executable.
Scripts for the build generally go in build-aux, so move soexpand.pl. soexpand.pl had the "executable" bit set, but it doesn't have a #! line and it's not a shell script, so that didn't make sense.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3cd56de1..0e2c6d79 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,7 @@ EXTRA_DIST = \
SubmittingPatches \
WHY-OVS \
boot.sh \
+ build-aux/soexpand.pl \
$(MAN_FRAGMENTS)
bin_PROGRAMS =
sbin_PROGRAMS =
@@ -81,15 +82,12 @@ scriptsdir = $(pkgdatadir)/scripts
# http://article.gmane.org/gmane.comp.sysutils.automake.general/10891
noinst_HEADERS += $(EXTRA_DIST)
-EXTRA_DIST += \
- soexpand.pl
-
ro_c = echo '/* -*- mode: c; buffer-read-only: t -*- */'
ro_shell = printf '\043 Generated automatically -- do not modify! -*- buffer-read-only: t -*-\n'
SUFFIXES += .in
.in:
- $(PERL) $(srcdir)/soexpand.pl -I$(srcdir) < $< | \
+ $(PERL) $(srcdir)/build-aux/soexpand.pl -I$(srcdir) < $< | \
sed \
-e 's,[@]PKIDIR[@],$(PKIDIR),g' \
-e 's,[@]LOGDIR[@],$(LOGDIR),g' \