aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEthan Jackson <ethan@nicira.com>2011-09-22 12:05:18 -0700
committerEthan Jackson <ethan@nicira.com>2011-09-27 11:38:30 -0700
commit6c88547dd0f75a29e6d1c0cd3c76d9678fa4752f (patch)
treec292e955a19f20a64f3c8595a01f85556660e06c /Makefile.am
parent484185ec4e1329bbc42cf0c0d70f24c732b748f8 (diff)
python: Backport argparse to older platforms.
Argparse has some convenient advantages over optparse including the ability to handle optional arguments to flags. It also supports parsing arguments as well as options. This patch copies argparse.py from Python 2.7 into a newly created compat directory. It made some very minor syntactic updates in the process. Platforms which have a Python version too old to include argparse by default will have this compat version installed as a workaround.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ec674b77..3cd56de1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,3 +181,4 @@ include ovsdb/automake.mk
include rhel/automake.mk
include xenserver/automake.mk
include python/ovs/automake.mk
+include python/compat/automake.mk