aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-06-17 12:24:31 -0700
committerBen Pfaff <blp@nicira.com>2011-06-17 12:53:52 -0700
commit43bb5f82ec051f335a5c5a8975150ec6352d5d73 (patch)
treecc129acfbd1ea5767f522860ca83d2499cf95c1e /Makefile.am
parentec610b7bf4f4890f50c2c7d2fbfe6120ad9312f1 (diff)
Refactor initscripts into distro-independent and distro-specific pieces.
This should make it easier to add OVS support to new distributions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f0e75711..ea6df2aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,9 +61,12 @@ noinst_man_MANS =
noinst_PROGRAMS =
noinst_SCRIPTS =
OVSIDL_BUILT =
+scripts_SCRIPTS =
SUFFIXES =
check_DATA =
+scriptsdir = $(pkgdatadir)/scripts
+
# This ensures that files added to EXTRA_DIST are always distributed,
# even if they are inside an Automake if...endif conditional block that is
# disabled by some particular "configure" run. For more information, see:
@@ -85,9 +88,12 @@ SUFFIXES += .in
-e 's,[@]PYTHON[@],$(PYTHON),g' \
-e 's,[@]RUNDIR[@],$(RUNDIR),g' \
-e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]BUILDNR[@],$(BUILDNR),g' \
-e 's,[@]localstatedir[@],$(localstatedir),g' \
-e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
-e 's,[@]sysconfdir[@],$(sysconfdir),g' \
+ -e 's,[@]bindir[@],$(bindir),g' \
+ -e 's,[@]sbindir[@],$(sbindir),g' \
-e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
-e 's,[@]ovsdbmonitordir[@],$(ovsdbmonitordir),g' \
> $@.tmp