aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2009-09-14 10:05:13 -0700
committerBen Pfaff <blp@nicira.com>2009-09-14 10:05:13 -0700
commit3b135da329687c69d3a0f1689621f75cc4888d6f (patch)
treefc9e7d86367e6dd0a787a354b6850c6f8b2ee440 /Makefile.am
parent39fb08818bbd9c438dbf23caa89937c663451b5a (diff)
New utility ovs-vsctl.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b49456b..60fd21ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,11 +51,22 @@ ro_c = echo '/* -*- mode: c; buffer-read-only: t -*- */'
SUFFIXES = .in
.in:
$(PERL) $(srcdir)/soexpand.pl -I$(srcdir) < $< | \
- sed -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
+ sed \
-e 's,[@]PKIDIR[@],$(PKIDIR),g' \
+ -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
+ -e 's,[@]PERL[@],$(PERL),g' \
+ -e 's,[@]PYTHON[@],$(PYTHON),g' \
-e 's,[@]RUNDIR[@],$(RUNDIR),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]localstatedir[@],$(localstatedir),g' \
-e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
- -e 's,[@]PERL[@],$(PERL),g' > $@
+ -e 's,[@]sysconfdir[@],$(sysconfdir),g' \
+ > $@.tmp
+ @if head -n 1 $@.tmp | grep -q '#!'; then \
+ echo chmod +x $@.tmp; \
+ chmod +x $@.tmp; \
+ fi
+ mv $@.tmp $@
include lib/automake.mk
include ofproto/automake.mk