aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2009-07-29 16:48:45 -0700
committerBen Pfaff <blp@nicira.com>2009-07-29 16:48:45 -0700
commit31a7c9e7766fed8e72b873850f3798801e442401 (patch)
tree628cad6cf1078ad56bb053fca8d0631255f046f2 /Makefile.am
parentc2b070214097fa40dc78252882d96babe7fab4b4 (diff)
Remove --disable-userspace "configure" option, since it breaks "make dist".
I had thought that Automake was smart enough to ignore conditionals around EXTRA_DIST, so that all files always got distributed regardless of whether Automake conditionals were set. I was wrong. This commit removes the --disable-userspace option to "configure", which put a conditional around most of Makefile.am and thus unintentionally caused most of the distribution to be left out if --disable-userspace was specified. The alternative (fixing --disable-userspace) seems like too much work--it would require pushing "if ENABLE_USERSPACE" down into lots of subdirectory--and would be difficult to maintain.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dccb8cfd..9413ce59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,6 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = datapath
-if ENABLE_USERSPACE
AM_CPPFLAGS = $(SSL_CFLAGS)
AM_CPPFLAGS += $(NCURSES_CFLAGS)
AM_CPPFLAGS += $(PCRE_CFLAGS)
@@ -72,4 +71,3 @@ if HAVE_PCRE
include extras/ezio/automake.mk
endif
endif
-endif # ENABLE_USERSPACE