aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-05-26 15:53:57 -0700
committerBen Pfaff <blp@nicira.com>2010-05-27 09:44:11 -0700
commit208d496f15787e55777c2ef541595f9e750ef771 (patch)
treef00491e11d424bb6b40da8a4125335254fb3e578 /Makefile.am
parent609d182a8161e9e87300cc680ff55c50d02b6e22 (diff)
debian: Attempt to keep debian/changelog up-to-date.
Invariably we forget to update the version number in debian/changelog as we change OVS's own version number. This is embarrassing. This commit introduces two different times to automatically update the debian/changelog version number: whenever boot.sh runs and whenever "make dist" runs. In the latter case, only the version number in the distributed tarball is updated, but that seems OK. Reported by Joan Cirer <joan@ev0.net> most recently, and by others over the last year or so too.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c23b670a..3a3ddb7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,9 @@ noinst_SCRIPTS =
OVSIDL_BUILT =
SUFFIXES =
-EXTRA_DIST += soexpand.pl
+EXTRA_DIST += \
+ build-aux/update-debian-changelog \
+ soexpand.pl
ro_c = echo '/* -*- mode: c; buffer-read-only: t -*- */'