aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2009-07-27 16:40:11 -0700
committerBen Pfaff <blp@nicira.com>2009-07-29 12:33:32 -0700
commit1b233b95b5907a242ee453cbea3ad4bc4cd4fec2 (patch)
tree8d6c415b2301fb036dfd4a907cd686191177ca68 /Makefile.am
parentbaa905d36b831881ceb20686f567dead3ec0bf14 (diff)
Use Autotest for the Open vSwitch test suite.
Autotest doesn't provide a lot of benefit by itself but it does allow us to easily put a wrapper around each test by using a macro to invoke it. (To do that with the built-in Automake test framework you need to write or generate a separate wrapper script for each test, which is a pain.) The next commit will take advantage of this possibility by adding support for code coverage analysis.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b40cdea..dccb8cfd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,8 +32,6 @@ EXTRA_DIST = INSTALL.bridge \
INSTALL.OpenFlow \
INSTALL.SSL \
INSTALL.XenServer
-TESTS =
-TESTS_ENVIRONMENT =
bin_PROGRAMS =
sbin_PROGRAMS =
bin_SCRIPTS =