aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-01-10 12:54:26 -0800
committerBen Pfaff <blp@nicira.com>2011-01-10 12:54:26 -0800
commit15b619e29d20708d2ce6946f1c5ec9841c4c822b (patch)
tree259eda6004f91f6fbc68f0995f622839e97ee4bf /Makefile.am
parenta87c35f1794474ed9d7696bdb762148dc65b0adb (diff)
tests: Fix Y2011 bug in testsuite.
The tests have been failing for a few days now, because the PKI expired a few days into 2011. This commit instead generates the PKI at "make check" time, which has the additional benefit of getting some test exposure for the ovs-pki program. Reported-by: Aaron M. Ucko <ucko@debian.org> CC: 609506@bugs.debian.org
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index eef8eb6b..689fd6cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2007, 2008, 2009, 2010 Nicira Networks, Inc.
+# Copyright (C) 2007, 2008, 2009, 2010, 2011 Nicira Networks, Inc.
#
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@@ -27,6 +27,7 @@ endif
ALL_LOCAL =
BUILT_SOURCES =
CLEANFILES =
+CLEAN_LOCAL =
DISTCLEANFILES =
EXTRA_DIST = \
CodingStyle \
@@ -60,6 +61,7 @@ noinst_PROGRAMS =
noinst_SCRIPTS =
OVSIDL_BUILT =
SUFFIXES =
+check_DATA =
# This ensures that files added to EXTRA_DIST are always distributed,
# even if they are inside an Automake if...endif conditional block that is
@@ -124,7 +126,8 @@ CLEANFILES += distfiles
dist-hook: $(DIST_HOOKS)
all-local: $(ALL_LOCAL)
-.PHONY: $(DIST_HOOKS)
+clean-local: $(CLEAN_LOCAL)
+.PHONY: $(DIST_HOOKS) $(CLEAN_LOCAL)
include lib/automake.mk
include ofproto/automake.mk