aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-12-08 14:23:54 -0800
committerBen Pfaff <blp@nicira.com>2010-12-08 17:09:29 -0800
commit00961f7cc5cb65e3d926a382748f231ded90d137 (patch)
treefbe2c11afdacea97ed489552a51351ae49515a1d /Makefile.am
parentd689a6a819c5bd4f4bde2c8766c0c7652b70eb3e (diff)
Avoid using "grep -q" outside of GNU/Linux specific utilities.
According to the Autoconf manual, "grep -q" is not portable, so instead redirect stdout to /dev/null.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8517b2b8..457513cb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,7 +88,7 @@ SUFFIXES += .in
-e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
-e 's,[@]ovsdbmonitordir[@],$(ovsdbmonitordir),g' \
> $@.tmp
- @if head -n 1 $@.tmp | grep -q '#!'; then \
+ @if head -n 1 $@.tmp | grep '#!' > /dev/null; then \
echo chmod +x $@.tmp; \
chmod +x $@.tmp; \
fi