aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-01-07 15:52:58 -0800
committerBen Pfaff <blp@nicira.com>2010-01-26 09:46:42 -0800
commit00732bf5b5da6f1d71dc4f4b42f54224c03f71f6 (patch)
tree8f3ed22139ab32e9dbaf8a28c889b006d3d14239 /Makefile.am
parentbda8868801ebe49b785f4810e055fb6bf80a1dc6 (diff)
Cleanly separate IDL annotations from OVSDB schema information.
Until now, the OVSDB IDL annotations have been glommed together with the schema information in a single file, and then we've used ovsdb-idlc to extract the schema from that file. This commit reverses the process: the schema and the annotations are stored separately and then glommed together as necessary at build time. This new arrangement has a few advantages: - We can now easily have multiple different sets of IDL annotations for a single OVSDB schema. For example, some users may not need access to columns that other users do. - Bugs in ovsdb-idlc cannot screw up the underlying schema (as shown by a recent commit).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bfba76f8..bb8245ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,7 @@ noinst_HEADERS =
noinst_LIBRARIES =
noinst_PROGRAMS =
noinst_SCRIPTS =
+OVSIDL_BUILT =
SUFFIXES =
EXTRA_DIST += soexpand.pl