aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJesse Gross <jesse@nicira.com>2012-12-06 14:14:02 -0800
committerJesse Gross <jesse@nicira.com>2012-12-06 14:20:04 -0800
commitfedbc4d62ec34af4fe1a48895b18c45e1c13e931 (patch)
tree0fcf1c06adf74233c00dbc83df007b361bca91ab /Makefile.am
parent9e4ba0085713535c8c75d2af00f77d3491f58de9 (diff)
Makefile.am: Exclude third-party code from config.h check.
It doesn't make sense to enforce our rules for code in the third- party directory. Signed-off-by: Jesse Gross <jesse@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 08cf395c..b00b82cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -175,7 +175,7 @@ config-h-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
git grep -L '#include <config\.h>' `git ls-files | grep '\.c$$' | \
- grep -vE '^datapath|^lib/sflow'`; \
+ grep -vE '^datapath|^lib/sflow|^third-party'`; \
then \
echo "See above for list of violations of the rule that"; \
echo "every C source file must #include <config.h>."; \