aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2012-07-25 10:25:55 -0700
committerBen Pfaff <blp@nicira.com>2012-07-25 12:39:41 -0700
commitb4e1bf8b7ef8704d857a9ee93d40719289b2139e (patch)
treefcc4b5fb4518fe057fa3049c449507909a1e3950 /Makefile.am
parent372d58a4e3d735a269856d1f285b5ed1b99f6dce (diff)
Makefiles: Enable "dist-hook-git" check only when GNU make is in use.
Otherwise, it will always fail because the Makefile in datapath/linux requires GNU make to generate the list of distributed files. Signed-off-by: Ben Pfaff <blp@nicira.com> Reported-by: Ed Maste <emaste@freebsd.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6615fd66..50c4b142 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,11 @@ CLEAN_LOCAL += clean-pycov
# If we're checked out from a Git repository, make sure that every
# file that is in Git is distributed.
+#
+# We only enable this check when GNU make is in use because the
+# Makefile in datapath/linux, needed to get the list of files to
+# distribute, requires GNU make extensions.
+if GNU_MAKE
ALL_LOCAL += dist-hook-git
dist-hook-git: distfiles
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \
@@ -148,7 +153,6 @@ dist-hook-git: distfiles
exit 1; \
fi; \
fi
-.PHONY: dist-hook-git
CLEANFILES += all-distfiles all-gitfiles missing-distfiles
# The following is based on commands for the Automake "distdir" target.
distfiles: Makefile
@@ -159,6 +163,8 @@ distfiles: Makefile
sed -e "s|^$$srcdirstrip/||;t" \
-e "s|^$$topsrcdirstrip/|$(top_builddir)/|;t" | sort -u > $@
CLEANFILES += distfiles
+endif
+.PHONY: dist-hook-git
# Check that "struct vlog_ratelimit" is always declared "static".
ALL_LOCAL += rate-limit-check