aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEd Maste <emaste@freebsd.org>2012-12-07 10:26:12 -0500
committerBen Pfaff <blp@nicira.com>2012-12-07 07:30:52 -0800
commitb411e5c35132f61cc1fd99dbeb1ed3f859d6f5ac (patch)
tree8971ebceecc021cd5ce6ab5a78504abdc1d93cb6 /Makefile.am
parentfedbc4d62ec34af4fe1a48895b18c45e1c13e931 (diff)
Prevent pager from appearing during build
The config.h check added in commit 9e4ba00 may bring up the pager during build (depending on git config). Signed-off-by: Ed Maste <emaste@freebsd.org> Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b00b82cc..fe6aa458 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -174,7 +174,7 @@ ALL_LOCAL += config-h-check
config-h-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
- git grep -L '#include <config\.h>' `git ls-files | grep '\.c$$' | \
+ git --no-pager grep -L '#include <config\.h>' `git ls-files | grep '\.c$$' | \
grep -vE '^datapath|^lib/sflow|^third-party'`; \
then \
echo "See above for list of violations of the rule that"; \