aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2023-06-06 16:06:34 +0300
committerMatias Elo <matias.elo@nokia.com>2023-06-09 20:09:06 +0300
commit08d3aa2ab01c5fa25c78fb9cc0899c55185c1718 (patch)
treef4dca9563c691fc85db45debf0965ef17e4e3884 /configure.ac
parent875d5bb720580f4695818dfc53e2bc38e215159e (diff)
api: increment ODP API version to 1.41.1v1.41.1.0
Increment API version number to reflect the following changes: Backward compatible: - dma: add odp_dma_compl_user_area() function for reading user area pointer - dma: clarify that DMA session names don't need to be unique - event: odp_event_user_area() function for reading user area pointer - init: add odp_term_abnormal() function that can be used to abnormally terminate an ODP application after a non-recoverable error - packet: extend packet transmit completion with poll mode - packet: add odp_packet_free_ctrl_set() function for controlling packet output interface to not free a packet after transmitting it - packet: add odp_packet_free_ctrl() function for reading packet's free control option value - pool: relax odp_pool_stats() specification to allow implementations to have some delay until pool statistics are updated - pool: add new function odp_pool_stats_selected() for reading only selected pool statistic(s) - timer: split odp_timer_cancel() failure reason into timing related and other failures - timer: rename odp_timer_set_t to odp_timer_retval_t - timer: add odp_timer_sample_ticks() function that samples tick value of multiple timer pools simultaneously - timer: allow implementation to place the first timer as close as it can to one period when starting a periodic timer with first_tick set to 0 - timer: clarify that periodic timer base frequency uses fractional numbers the same way as timer tick info - timer: clarify that odp_timer_periodic_capability() call does not overwrite the base frequency value when 1 is returned - timer: clarify that some implementations may support only certain periodic timer base frequencies and those depend on source clock frequency Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 576001acd..ae9967c76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ AC_PREREQ([2.5])
##########################################################################
m4_define([odp_version_generation], [1])
m4_define([odp_version_major], [41])
-m4_define([odp_version_minor], [0])
+m4_define([odp_version_minor], [1])
m4_define([odp_version_patch], [0])
m4_define([odp_version_api],