aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@linaro.org>2018-09-27 15:00:49 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2018-10-09 17:24:50 +0300
commit406054d9c9ce31990d59640aa5d3dfd49e2d1e9d (patch)
treebf22655b36fb119e7b62d9bdc7fc061c7c8d9244 /Makefile.am
parentb7da3cd005ab576b55e066ffa854697f41bb6f82 (diff)
test: build: configure option to disable test build
Test applications are not always needed. Added a configuration option to disable test application build and install. This makes build faster and install footprint smaller. Signed-off-by: Petri Savolainen <petri.savolainen@linaro.org> Reviewed-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9038203a9..e4dab7e38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,15 +12,18 @@ SUBDIRS = \
include \
$(PLATFORM_DIR) \
helper \
- test \
- $(PLATFORM_TEST_DIR) \
- helper/test \
doc
if WITH_EXAMPLES
SUBDIRS += example
endif
+if WITH_TESTS
+SUBDIRS += test
+SUBDIRS += helper/test
+SUBDIRS += $(PLATFORM_TEST_DIR)
+endif
+
@DX_RULES@
EXTRA_DIST = bootstrap CHANGELOG config/README config/odp-$(with_platform).conf