aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@nokia.com>2020-09-11 16:37:57 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2020-09-15 10:47:02 +0300
commit1a7777a3fcca30c5d375719116ce0aeda911c35e (patch)
treebee73d9dc0ca502e8b5cee858c2c474c58f79724 /Makefile.am
parent2efeae667f413dd22d1f1bea949d3c9f0dab1bb3 (diff)
test: run validation tests before other tests
Change test execution order during 'make check', so that validation tests are run before other tests. Example tests are run before performance (and platform specific) tests as example tests are simpler and run faster (involves less packet IO). Makefile.am in test directory became empty and was removed. Signed-off-by: Petri Savolainen <petri.savolainen@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b2e828ce1..b8eb46f0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,12 +16,20 @@ SUBDIRS = \
helper \
doc
+# Tests are run in this SUBDIRS order. The intention is to run validation tests first,
+# then example/performance/platform specific tests.
+if WITH_TESTS
+SUBDIRS += test/common
+SUBDIRS += test/miscellaneous
+SUBDIRS += test/validation
+endif
+
if WITH_EXAMPLES
SUBDIRS += example
endif
if WITH_TESTS
-SUBDIRS += test
+SUBDIRS += test/performance
SUBDIRS += helper/test
SUBDIRS += $(PLATFORM_TEST_DIR)
endif