aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-generic/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'platform/linux-generic/test/Makefile.am')
-rw-r--r--platform/linux-generic/test/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/platform/linux-generic/test/Makefile.am b/platform/linux-generic/test/Makefile.am
index 1f7ae611e..049ce2187 100644
--- a/platform/linux-generic/test/Makefile.am
+++ b/platform/linux-generic/test/Makefile.am
@@ -8,25 +8,13 @@ TESTS_ENVIRONMENT += WITH_OPENSSL=0
endif
SUBDIRS =
-
-if WITH_EXAMPLES
-TESTS = ipsec/ipsec_api_example.sh \
- ipsec/ipsec_crypto_example.sh
-
-dist_check_SCRIPTS = ipsec/ipsec_api_example.sh \
- ipsec/ipsec_crypto_example.sh
-else
TESTS =
-dist_check_SCRIPTS =
-endif
if test_vald
TESTS += validation/api/pktio/pktio_run.sh \
validation/api/pktio/pktio_run_tap.sh \
validation/api/shmem/shmem_linux$(EXEEXT)
-test_SCRIPTS = $(dist_check_SCRIPTS)
-
SUBDIRS += validation/api/pktio\
validation/api/shmem\
pktio_ipc \
@@ -69,25 +57,3 @@ if test_installdir
installcheck-local:
$(DESTDIR)/$(testdir)/run-test.sh $(TESTNAME)
endif
-
-# If building out-of-tree, make check will not copy the scripts and data to the
-# $(builddir) assuming that all commands are run locally. However this prevents
-# running tests on a remote target using LOG_COMPILER.
-# So copy all script and data files explicitly here.
-all-local:
- if [ "x$(srcdir)" != "x$(builddir)" ]; then \
- for f in $(dist_check_SCRIPTS); do \
- if [ -e $(srcdir)/$$f ]; then \
- mkdir -p $(builddir)/$$(dirname $$f); \
- cp -f $(srcdir)/$$f $(builddir)/$$f; \
- fi \
- done \
- fi
-clean-local:
- if [ "x$(srcdir)" != "x$(builddir)" ]; then \
- for f in $(dist_check_SCRIPTS); do \
- rm -f $(builddir)/$$f; \
- done \
- fi
-
-.NOTPARALLEL: