aboutsummaryrefslogtreecommitdiff
path: root/example/ipsec_crypto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/ipsec_crypto/Makefile.am')
-rw-r--r--example/ipsec_crypto/Makefile.am38
1 files changed, 26 insertions, 12 deletions
diff --git a/example/ipsec_crypto/Makefile.am b/example/ipsec_crypto/Makefile.am
index 2e3652252..1db0d72d0 100644
--- a/example/ipsec_crypto/Makefile.am
+++ b/example/ipsec_crypto/Makefile.am
@@ -2,16 +2,28 @@ include $(top_srcdir)/example/Makefile.inc
bin_PROGRAMS = odp_ipsec_crypto
-dist_check_SCRIPTS = \
- odp_ipsec_crypto_run_ah_in.sh \
- odp_ipsec_crypto_run_ah_out.sh \
- odp_ipsec_crypto_run_both_in.sh \
- odp_ipsec_crypto_run_both_out.sh \
- odp_ipsec_crypto_run_esp_in.sh \
- odp_ipsec_crypto_run_esp_out.sh \
- odp_ipsec_crypto_run_live.sh \
- odp_ipsec_crypto_run_router.sh \
- odp_ipsec_crypto_run_simple.sh
+if test_example
+TESTS = \
+ odp_ipsec_crypto_run_ah_in.sh \
+ odp_ipsec_crypto_run_ah_out.sh \
+ odp_ipsec_crypto_run_both_in.sh \
+ odp_ipsec_crypto_run_both_out.sh \
+ odp_ipsec_crypto_run_esp_in.sh \
+ odp_ipsec_crypto_run_esp_out.sh \
+ odp_ipsec_crypto_run_live.sh \
+ odp_ipsec_crypto_run_router.sh \
+ odp_ipsec_crypto_run_simple.sh
+endif
+EXTRA_DIST = \
+ odp_ipsec_crypto_run_ah_in.sh \
+ odp_ipsec_crypto_run_ah_out.sh \
+ odp_ipsec_crypto_run_both_in.sh \
+ odp_ipsec_crypto_run_both_out.sh \
+ odp_ipsec_crypto_run_esp_in.sh \
+ odp_ipsec_crypto_run_esp_out.sh \
+ odp_ipsec_crypto_run_live.sh \
+ odp_ipsec_crypto_run_router.sh \
+ odp_ipsec_crypto_run_simple.sh
odp_ipsec_crypto_SOURCES = \
odp_ipsec.c \
@@ -43,16 +55,18 @@ endif
# So copy all script and data files explicitly here.
all-local:
if [ "x$(srcdir)" != "x$(builddir)" ]; then \
- for f in $(dist_check_SCRIPTS); do \
+ for f in $(EXTRA_DIST); do \
if [ -e $(srcdir)/$$f ]; then \
mkdir -p $(builddir)/$$(dirname $$f); \
cp -f $(srcdir)/$$f $(builddir)/$$f; \
fi \
done \
fi
+ ln -f -s ../../platform/$(with_platform)/test/example/ipsec_crypto/pktio_env pktio_env
clean-local:
if [ "x$(srcdir)" != "x$(builddir)" ]; then \
- for f in $(dist_check_SCRIPTS); do \
+ for f in $(EXTRA_DIST); do \
rm -f $(builddir)/$$f; \
done \
fi
+ rm -f pktio_env