aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 656246cfc..9167c3219 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,22 +113,6 @@ AC_SUBST([with_platform])
AC_SUBST([platform_with_platform], ["platform/${with_platform}"])
##########################################################################
-# Run platform specific checks and settings
-##########################################################################
-IMPLEMENTATION_NAME=""
-if test "${with_platform}" == "linux-generic";
-then
- m4_include([./platform/linux-generic/m4/configure.m4])
- m4_include([./test/platform/linux-generic/m4/configure.m4])
- IMPLEMENTATION_NAME="odp-linux"
-else
- echo "UNSUPPORTED PLATFORM: ${with_platform}"
- exit 1
-fi
-
-ODP_CFLAGS="$ODP_CFLAGS -DIMPLEMENTATION_NAME=$IMPLEMENTATION_NAME"
-
-##########################################################################
# Include m4 files
##########################################################################
m4_include([./doc/m4/configure.m4])
@@ -158,7 +142,7 @@ IMPLEMENTATION_NAME=""
if test "${with_platform}" == "linux-dpdk";
then
m4_include([./platform/linux-dpdk/m4/configure.m4])
- m4_include([./test/linux-dpdk/m4/configure.m4])
+ m4_include([./test/platform/linux-dpdk/m4/configure.m4])
IMPLEMENTATION_NAME="odp-dpdk"
else
echo "UNSUPPORTED PLATFORM: ${with_platform}"