aboutsummaryrefslogtreecommitdiff
path: root/test/common/Makefile.am
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@nokia.com>2021-04-14 14:58:41 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2021-04-19 10:09:53 +0300
commitd772453adbde43ee45974cdc5753cf643b350665 (patch)
treeab2d7fb130d603228f187ff0a0d25449216fded3 /test/common/Makefile.am
parent50fdac45f35e83b183419eb7671df9686645afec (diff)
validation: common: split test packet header file
Split test_packet_parser.h file into protocol specific header files. It's easier find and maintain test packets when those are sorted per protocol. Signed-off-by: Petri Savolainen <petri.savolainen@nokia.com> Reviewed-by: Jere Leppänen <jere.leppanen@nokia.com>
Diffstat (limited to 'test/common/Makefile.am')
-rw-r--r--test/common/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/common/Makefile.am b/test/common/Makefile.am
index 79146e01c..9e9ecca98 100644
--- a/test/common/Makefile.am
+++ b/test/common/Makefile.am
@@ -14,5 +14,9 @@ libthrmask_common_la_CFLAGS = $(AM_CFLAGS) -DTEST_THRMASK
endif
-noinst_HEADERS = test_packet_parser.h
+noinst_HEADERS = test_packet_custom.h \
+ test_packet_ipsec.h \
+ test_packet_ipv4.h \
+ test_packet_ipv6.h
+
dist_test_SCRIPTS = run-test.sh