aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-generic/Makefile.am
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2020-09-02 16:17:00 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2020-09-08 16:08:35 +0300
commite39b3a9171696992a8c1a510f0cdf78d94c87d7a (patch)
tree1b04fa7abc124a0175bbd4802522cf9cdfb7184c /platform/linux-generic/Makefile.am
parentd38a0bdd9eae957c6464b62efbc06e7184898b56 (diff)
linux-gen: random: always build both implementations
Always build both random module implementations to detect possible build issues. Renamed random_null implementation to random_std. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'platform/linux-generic/Makefile.am')
-rw-r--r--platform/linux-generic/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/platform/linux-generic/Makefile.am b/platform/linux-generic/Makefile.am
index 33be2f575..868f1e9fb 100644
--- a/platform/linux-generic/Makefile.am
+++ b/platform/linux-generic/Makefile.am
@@ -127,6 +127,8 @@ noinst_HEADERS = \
include/odp_queue_basic_internal.h \
include/odp_queue_lf.h \
include/odp_queue_scalable_internal.h \
+ include/odp_random_std_internal.h \
+ include/odp_random_openssl_internal.h \
include/odp_ring_common.h \
include/odp_ring_internal.h \
include/odp_ring_mpmc_internal.h \
@@ -193,6 +195,9 @@ __LIB__libodp_linux_la_SOURCES = \
odp_queue_lf.c \
odp_queue_scalable.c \
odp_queue_spsc.c \
+ odp_random.c \
+ odp_random_std.c \
+ odp_random_openssl.c \
odp_rwlock.c \
odp_rwlock_recursive.c \
odp_schedule_basic.c \
@@ -234,12 +239,10 @@ __LIB__libodp_linux_la_SOURCES = \
if WITH_OPENSSL
__LIB__libodp_linux_la_SOURCES += \
- odp_crypto_openssl.c \
- odp_random_openssl.c
+ odp_crypto_openssl.c
else
__LIB__libodp_linux_la_SOURCES += \
- odp_crypto_null.c \
- odp_random_null.c
+ odp_crypto_null.c
endif
if ODP_ABI_COMPAT
__LIB__libodp_linux_la_SOURCES += \