aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-generic/Makefile.am
diff options
context:
space:
mode:
authorTuomas Taipale <tuomas.taipale@nokia.com>2022-04-02 06:11:26 +0000
committerMatias Elo <matias.elo@nokia.com>2022-05-02 17:02:50 +0300
commit5f40ae132514316fa73ff5c311e185350f9189dd (patch)
treed696d46f0079f545cc70492b642b9cf00053152f /platform/linux-generic/Makefile.am
parentf20ea066401dd189253967bc78e4e28fc142c6c3 (diff)
linux-gen: pool: add memory source operations interface
New `_odp_pool_mem_src_ops_t` interface can be used to adapt ODP packet pools to be used as a memory source for e.g. zero-copy packet IO purposes. For now, pools can only be assigned to a single operations provider. When an active memory source user is found, rest are disabled to avoid conflicting configurations. Signed-off-by: Tuomas Taipale <tuomas.taipale@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'platform/linux-generic/Makefile.am')
-rw-r--r--platform/linux-generic/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/platform/linux-generic/Makefile.am b/platform/linux-generic/Makefile.am
index 49565502f..d76dd81e1 100644
--- a/platform/linux-generic/Makefile.am
+++ b/platform/linux-generic/Makefile.am
@@ -209,6 +209,7 @@ __LIB__libodp_linux_la_SOURCES = \
odp_parse.c \
odp_pkt_queue.c \
odp_pool.c \
+ odp_pool_mem_src_ops.c \
odp_queue_basic.c \
odp_queue_if.c \
odp_queue_lf.c \