aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-generic/Makefile.am
diff options
context:
space:
mode:
authorStanislaw Kardach <skardach@marvell.com>2020-04-23 14:50:42 +0200
committerMatias Elo <matias.elo@nokia.com>2020-09-07 13:38:00 +0300
commit091369b4167b6446da465a82bc6f33c7cfc52a1c (patch)
tree7d331bb6bce71cb2c30618e5099cdd7dff159cbd /platform/linux-generic/Makefile.am
parent12016da75a670525195ec0c00fc5fdd0a58fc9f7 (diff)
build: use more generic naming for PCAP PKTIO test
PCAP pktio is a platform specific concept which is used throughout the examples and tests. Therefore rename it so that it's more clear that this flag is checking whether there is a PCAP pktio support rather than PCAP libraries available. Signed-off-by: Stanislaw Kardach <skardach@marvell.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'platform/linux-generic/Makefile.am')
-rw-r--r--platform/linux-generic/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/platform/linux-generic/Makefile.am b/platform/linux-generic/Makefile.am
index 267d02a7d..33be2f575 100644
--- a/platform/linux-generic/Makefile.am
+++ b/platform/linux-generic/Makefile.am
@@ -339,7 +339,7 @@ noinst_HEADERS += arch/x86/cpu_flags.h \
arch/default/odp_cpu_idling.h
endif
-if HAVE_PCAP
+if ODP_PKTIO_PCAP
__LIB__libodp_linux_la_SOURCES += pktio/pcap.c
endif
@@ -350,6 +350,6 @@ __LIB__libodp_linux_la_LIBADD += $(DPDK_LIBS_LIBODP)
__LIB__libodp_linux_la_LIBADD += $(PTHREAD_LIBS)
__LIB__libodp_linux_la_LIBADD += $(TIMER_LIBS)
-if HAVE_PCAP
+if ODP_PKTIO_PCAP
__LIB__libodp_linux_la_LIBADD += $(PCAP_LIBS)
endif