aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-dpdk/Makefile.am
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2019-10-17 17:28:35 +0300
committerMatias Elo <matias.elo@nokia.com>2021-10-04 11:52:54 +0300
commitade7bd3fb7ee4b4bdf156bd2f1b6181fb72aa219 (patch)
tree2a8b1b0825c695c5f06cd26a12ff5f77290b3233 /platform/linux-dpdk/Makefile.am
parent1d6480ed4a08a056b06c303148b900d9ac616df2 (diff)
linux-dpdk: thread: add internal helper function for reading active cpu ids
_odp_thread_cpu_ids() writes the CPU IDs of active ODP threads to the output array. This information is required by the alternate DPDK timer implementation. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Jere Leppänen <jere.leppanen@nokia.com>
Diffstat (limited to 'platform/linux-dpdk/Makefile.am')
-rw-r--r--platform/linux-dpdk/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/platform/linux-dpdk/Makefile.am b/platform/linux-dpdk/Makefile.am
index 480851436..61b61f6d6 100644
--- a/platform/linux-dpdk/Makefile.am
+++ b/platform/linux-dpdk/Makefile.am
@@ -138,6 +138,7 @@ noinst_HEADERS = \
${top_srcdir}/platform/linux-generic/include/odp_sorted_list_internal.h \
${top_srcdir}/platform/linux-generic/include/odp_sysinfo_internal.h \
include/odp_shm_internal.h \
+ include/odp_thread_internal.h \
${top_srcdir}/platform/linux-generic/include/odp_timer_internal.h \
${top_srcdir}/platform/linux-generic/include/odp_timer_wheel_internal.h \
${top_srcdir}/platform/linux-generic/include/odp_traffic_mngr_internal.h \