aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-dpdk/Makefile.am
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2018-05-07 13:13:56 +0300
committerMatias Elo <matias.elo@nokia.com>2019-06-07 16:39:46 +0300
commit12850f1cad3e54c1d2cd29f7a702955c1bc8b517 (patch)
tree6f108e2e8a68f0bcb508330301f7cb9f35471e02 /platform/linux-dpdk/Makefile.am
parent258a10e061fd2633a957937e4ad147fc011e3ea3 (diff)
linux-dpdk: initial experimental eventdev support
Add DPDK eventdev based new scheduler and queue implementations. The initial implementation has been validated using only the standard software eventdev poll mode driver with DPDK v18.11. To use eventdev one must set ODP_SCHEDULER environment variable to "eventdev" and provide the necessary platform parameters to DPDK. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'platform/linux-dpdk/Makefile.am')
-rw-r--r--platform/linux-dpdk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/platform/linux-dpdk/Makefile.am b/platform/linux-dpdk/Makefile.am
index f7918da2e..14b5f6186 100644
--- a/platform/linux-dpdk/Makefile.am
+++ b/platform/linux-dpdk/Makefile.am
@@ -93,6 +93,7 @@ noinst_HEADERS = \
${top_srcdir}/platform/linux-generic/include/odp_classification_datamodel.h \
${top_srcdir}/platform/linux-generic/include/odp_classification_inlines.h \
${top_srcdir}/platform/linux-generic/include/odp_classification_internal.h \
+ include/odp_eventdev_internal.h \
${top_srcdir}/platform/linux-generic/include/odp_forward_typedefs_internal.h \
${top_srcdir}/platform/linux-generic/include/odp_global_data.h \
${top_srcdir}/platform/linux-generic/include/odp_init_internal.h \
@@ -177,12 +178,14 @@ __LIB__libodp_linux_la_SOURCES = \
../linux-generic/odp_pkt_queue.c \
odp_pool.c \
odp_queue_basic.c \
+ odp_queue_eventdev.c \
odp_queue_if.c \
../linux-generic/odp_queue_lf.c \
odp_queue_spsc.c \
../linux-generic/odp_rwlock.c \
../linux-generic/odp_rwlock_recursive.c \
../linux-generic/odp_schedule_basic.c \
+ odp_schedule_eventdev.c \
odp_schedule_if.c \
../linux-generic/odp_schedule_sp.c \
odp_shared_memory.c \