aboutsummaryrefslogtreecommitdiff
path: root/helper/test/Makefile.am
diff options
context:
space:
mode:
authorChristophe Milard <christophe.milard@linaro.org>2016-04-15 10:38:13 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-05-23 15:06:58 +0300
commitff0f5ec4d5cb871890e8a3dadabb4fe748f6c419 (patch)
treefdf553ee981fee6ede13f97d9879d8311d00dc8f /helper/test/Makefile.am
parent03a915e00c04ac53a63dc42c9206d82926f5ad4f (diff)
helper: test: adding odpthread functions tests
Simple tests testing odph_odpthreads_create() and odph_odpthreads_join() are added. A single test binary, odpthreads, is added. This program creates odp threads as pthreads or linux processes, dependng on its calling args. Two calling scripts are added to create ODP threads as either processes, or threads. Signed-off-by: Christophe Milard <christophe.milard@linaro.org> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com> Reviewed-by: Brian Brooks <brian.brooks@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/test/Makefile.am')
-rw-r--r--helper/test/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/helper/test/Makefile.am b/helper/test/Makefile.am
index 7f0b67d58..8e6594865 100644
--- a/helper/test/Makefile.am
+++ b/helper/test/Makefile.am
@@ -11,9 +11,10 @@ EXECUTABLES = chksum$(EXEEXT) \
process$(EXEEXT)\
table$(EXEEXT)
-COMPILE_ONLY =
+COMPILE_ONLY = odpthreads
-TESTSCRIPTS =
+TESTSCRIPTS = odpthreads_as_processes \
+ odpthreads_as_pthreads
if test_helper
TESTS = $(EXECUTABLES) $(TESTSCRIPTS)
@@ -25,6 +26,8 @@ bin_PROGRAMS = $(EXECUTABLES) $(COMPILE_ONLY)
dist_chksum_SOURCES = chksum.c
+dist_odpthreads_SOURCES = odpthreads.c
+odpthreads_LDADD = $(LIB)/libodphelper-linux.la $(LIB)/libodp-linux.la
dist_thread_SOURCES = thread.c
thread_LDADD = $(LIB)/libodphelper-linux.la $(LIB)/libodp-linux.la
dist_process_SOURCES = process.c