aboutsummaryrefslogtreecommitdiff
path: root/helper/test/Makefile.am
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2015-05-12 17:32:11 -0400
committerMike Holmes <mike.holmes@linaro.org>2015-05-27 08:38:25 -0400
commitee48c657b52d0f8dd8a11c18c62bce8920935c3e (patch)
treea43b3ec28406a3d82f2e0b2fc8578fcf33b65ae5 /helper/test/Makefile.am
parenta9cc0fc700a4a8b9589404a18136b01974ca4aa3 (diff)
test: helper: add process and thread tests
The helpers need to be tested independently from the ODP API, create a folder to contain helper tests, adding tests for process and thread creation. Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Christophe Milard <christophe.milard@linaro.org>
Diffstat (limited to 'helper/test/Makefile.am')
-rw-r--r--helper/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/helper/test/Makefile.am b/helper/test/Makefile.am
new file mode 100644
index 000000000..f33053348
--- /dev/null
+++ b/helper/test/Makefile.am
@@ -0,0 +1,25 @@
+include $(top_srcdir)/test/Makefile.inc
+
+AM_CFLAGS += -I$(srcdir)/common
+AM_LDFLAGS += -static
+
+TESTS_ENVIRONMENT = ODP_PLATFORM=${with_platform} TEST_DIR=${builddir}
+
+EXECUTABLES = odp_thread \
+ odp_process
+
+COMPILE_ONLY =
+
+TESTSCRIPTS =
+
+if test_helper
+TESTS = $(EXECUTABLES) $(TESTSCRIPTS)
+endif
+
+dist_bin_SCRIPTS =
+
+bin_PROGRAMS = $(EXECUTABLES) $(COMPILE_ONLY)
+
+
+dist_odp_thread_SOURCES = odp_thread.c
+dist_odp_process_SOURCES = odp_process.c