aboutsummaryrefslogtreecommitdiff
path: root/helper/test/Makefile.am
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@nokia.com>2016-02-09 14:25:07 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-03-03 22:32:04 +0300
commitcc03b63e667c3acf580f20765910dbb342d452b2 (patch)
tree491fc29041a2f0e75f9e4f89bfc1ae7ad268de80 /helper/test/Makefile.am
parent0ebc7f2d0788a2adec58e25032ba2317f9e089ac (diff)
helper: eth: added mac address parse
Ethernet MAC address parse function is commonly needed by test applications. A common parse function harmonizes the definition of MAC address as a command line parameter. Signed-off-by: Petri Savolainen <petri.savolainen@nokia.com> Reviewed-by: Juha-Matti Tilli <juha-matti.tilli@nokia.com> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/test/Makefile.am')
-rw-r--r--helper/test/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/helper/test/Makefile.am b/helper/test/Makefile.am
index bbad2a58b..918638175 100644
--- a/helper/test/Makefile.am
+++ b/helper/test/Makefile.am
@@ -7,6 +7,7 @@ TESTS_ENVIRONMENT += TEST_DIR=${builddir}
EXECUTABLES = odp_chksum$(EXEEXT) \
odp_thread$(EXEEXT) \
+ odp_parse$(EXEEXT)\
odp_process$(EXEEXT)\
odp_table$(EXEEXT)
@@ -26,6 +27,7 @@ bin_PROGRAMS = $(EXECUTABLES) $(COMPILE_ONLY)
dist_odp_chksum_SOURCES = odp_chksum.c
dist_odp_thread_SOURCES = odp_thread.c
odp_thread_LDADD = $(LIB)/libodphelper.la $(LIB)/libodp.la
+dist_odp_parse_SOURCES = odp_parse.c
dist_odp_process_SOURCES = odp_process.c
odp_process_LDADD = $(LIB)/libodphelper.la $(LIB)/libodp.la
dist_odp_table_SOURCES = odp_table.c