aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2018-02-01 10:16:37 +0200
committerMatias Elo <matias.elo@nokia.com>2018-02-01 10:16:37 +0200
commite79db7d5662a3b83a39baad69aecc346b4ea4065 (patch)
tree832db5d257721b453b92c2e5523b5a34f432267c /helper/Makefile.am
parent9c8e5413f78c21039434111100bbb857b28b3bdb (diff)
parent482eeee380d40596131826c1103ed89247bd17e5 (diff)
Merge commit '482eeee380d40596131826c1103ed89247bd17e5' of https://github.com/Linaro/odp into odp-dpdk
Signed-off-by: Matias Elo <matias.elo@nokia.com> # Conflicts: # configure.ac # example/Makefile.inc # helper/test/Makefile.am # platform/Makefile.inc # platform/linux-generic/libodp-linux.pc.in
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am57
1 files changed, 29 insertions, 28 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index b34d0d5d5..5d0307313 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -1,50 +1,51 @@
include $(top_srcdir)/platform/@with_platform@/Makefile.inc
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = $(top_builddir)/pkgconfig/libodphelper.pc
+pkgconfig_DATA = libodphelper.pc
LIB = $(top_builddir)/lib
-AM_CPPFLAGS = -I$(srcdir)/include
-AM_CPPFLAGS += -I$(top_srcdir)/platform/@with_platform@/include
-AM_CPPFLAGS += -I$(top_srcdir)/include
-AM_CPPFLAGS += -I$(top_srcdir)/include/odp/arch/@ARCH_ABI@
-AM_CPPFLAGS += -I$(top_builddir)/platform/@with_platform@/include
-AM_CPPFLAGS += -I$(top_srcdir)/platform/@with_platform@/arch/@ARCH_DIR@
-AM_CPPFLAGS += -I$(top_builddir)/include
+AM_CPPFLAGS = \
+ -I$(top_builddir)/platform/@with_platform@/include \
+ -I$(top_srcdir)/helper/include \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/include/odp/arch/@ARCH_ABI@ \
+ -I$(top_srcdir)/platform/@with_platform@/include \
+ -I$(top_srcdir)/platform/@with_platform@/arch/@ARCH_DIR@ \
+ -I$(top_builddir)/include
AM_LDFLAGS = -version-number '$(ODPHELPER_LIBSO_VERSION)'
helperincludedir = $(includedir)/odp/helper/
helperinclude_HEADERS = \
- $(srcdir)/include/odp/helper/chksum.h\
- $(srcdir)/include/odp/helper/eth.h\
- $(srcdir)/include/odp/helper/icmp.h\
- $(srcdir)/include/odp/helper/ip.h\
- $(srcdir)/include/odp/helper/ipsec.h\
- $(srcdir)/include/odp/helper/odph_api.h\
- $(srcdir)/include/odp/helper/odph_cuckootable.h\
- $(srcdir)/include/odp/helper/odph_hashtable.h\
- $(srcdir)/include/odp/helper/odph_iplookuptable.h\
- $(srcdir)/include/odp/helper/odph_lineartable.h\
- $(srcdir)/include/odp/helper/strong_types.h\
- $(srcdir)/include/odp/helper/tcp.h\
- $(srcdir)/include/odp/helper/table.h\
- $(srcdir)/include/odp/helper/threads.h \
- $(srcdir)/include/odp/helper/udp.h
+ include/odp/helper/chksum.h\
+ include/odp/helper/eth.h\
+ include/odp/helper/icmp.h\
+ include/odp/helper/ip.h\
+ include/odp/helper/ipsec.h\
+ include/odp/helper/odph_api.h\
+ include/odp/helper/odph_cuckootable.h\
+ include/odp/helper/odph_hashtable.h\
+ include/odp/helper/odph_iplookuptable.h\
+ include/odp/helper/odph_lineartable.h\
+ include/odp/helper/strong_types.h\
+ include/odp/helper/tcp.h\
+ include/odp/helper/table.h\
+ include/odp/helper/threads.h \
+ include/odp/helper/udp.h
if helper_linux
helperinclude_HEADERS += \
- $(srcdir)/include/odp/helper/linux.h
+ include/odp/helper/linux.h
helperlinuxincludedir = $(includedir)/odp/helper/linux
helperlinuxinclude_HEADERS = \
- $(srcdir)/include/odp/helper/linux/pthread.h \
- $(srcdir)/include/odp/helper/linux/process.h
+ include/odp/helper/linux/pthread.h \
+ include/odp/helper/linux/process.h
endif
noinst_HEADERS = \
- $(srcdir)/include/odph_debug.h \
- $(srcdir)/include/odph_list_internal.h
+ include/odph_debug.h \
+ include/odph_list_internal.h
__LIB__libodphelper_la_SOURCES = \
eth.c \