aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorJere Leppänen <jere.leppanen@nokia.com>2021-02-18 15:07:24 +0200
committerPetri Savolainen <petri.savolainen@nokia.com>2021-02-23 11:01:07 +0200
commitb1b10b702674378905a9cca643f7d404a3ca15db (patch)
treeff5f885831cc12635525fa8c2228ee1c51b7b3c9 /helper/Makefile.am
parent84b6587531ea50a9de473587af52cdf39f7e9dd9 (diff)
configure: add with-libcli-path option
Allow user to specify the location of libcli headers and libraries, in case libcli is installed outside the normal search paths. Also, move all the libcli related logic to a separate libcli.m4 file. Signed-off-by: Jere Leppänen <jere.leppanen@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 9aef4f4ec..95167c3be 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -5,7 +5,8 @@ pkgconfig_DATA = libodphelper.pc
AM_CPPFLAGS = \
$(ODP_INCLUDES) \
- $(HELPER_INCLUDES)
+ $(HELPER_INCLUDES) \
+ $(LIBCLI_CPPFLAGS)
AM_CFLAGS = $(PTHREAD_CFLAGS)
AM_LDFLAGS = -version-number '$(ODPHELPER_LIBSO_VERSION)'