aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2017-01-23 14:46:06 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-01-25 19:25:50 +0300
commit88ed645e7378b955c580ec2b8ce9b846a5fb48f0 (patch)
treedd8c3f5aec50744f946b176a5b3dd60fed91d7db /helper/Makefile.am
parent722fd6f8286722d30d50c00769fa4fcad5935dd2 (diff)
helper: use odph_api.h for test include for unexported files
Adding the previously missing table functions to the public helper api allows the tests to use just odph_api.h Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Christophe Milard <christophe.milard@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 76cad1b7b..4d24a6913 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -20,6 +20,10 @@ helperinclude_HEADERS = \
$(srcdir)/include/odp/helper/ip.h\
$(srcdir)/include/odp/helper/ipsec.h\
$(srcdir)/include/odp/helper/odph_api.h\
+ $(srcdir)/include/odp/helper/odph_cuckootable.h\
+ $(srcdir)/include/odp/helper/odph_hashtable.h\
+ $(srcdir)/include/odp/helper/odph_iplookuptable.h\
+ $(srcdir)/include/odp/helper/odph_lineartable.h\
$(srcdir)/include/odp/helper/strong_types.h\
$(srcdir)/include/odp/helper/tcp.h\
$(srcdir)/include/odp/helper/table.h\
@@ -33,11 +37,7 @@ endif
noinst_HEADERS = \
$(srcdir)/odph_debug.h \
- $(srcdir)/odph_hashtable.h \
- $(srcdir)/odph_lineartable.h \
- $(srcdir)/odph_cuckootable.h \
- $(srcdir)/odph_list_internal.h \
- $(srcdir)/odph_iplookuptable.h
+ $(srcdir)/odph_list_internal.h
__LIB__libodphelper_@with_platform@_la_SOURCES = \
eth.c \