aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorJere Leppänen <jere.leppanen@nokia.com>2021-02-22 15:53:03 +0200
committerPetri Savolainen <petri.savolainen@nokia.com>2021-02-26 15:09:58 +0200
commit21cd5e4e309a24a81bfdea2b998a83426891876a (patch)
tree6224937581a70600420ea7f751358d891f82a215 /helper/Makefile.am
parent706e1e6b24a40bfd9c2b07f084af47532bc2141f (diff)
build: check names of global symbols in static libraries
Add tests to check that global symbols in static libodp-linux and libodphelper conform to certain prefix patterns. Fixes: https://github.com/OpenDataPlane/odp/issues/805 Signed-off-by: Jere Leppänen <jere.leppanen@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 95167c3be..264b3d365 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -79,3 +79,16 @@ __LIB__libodphelper_la_LIBADD = $(PTHREAD_LIBS)
__LIB__libodphelper_la_LIBADD += $(LIBCLI_LIBS)
lib_LTLIBRARIES = $(LIB)/libodphelper.la
+
+CHECK_GLOBALS_REGEX = " odph_"
+
+TESTS_ENVIRONMENT = \
+ LIBTOOL="$(LIBTOOL)" \
+ NM="$(NM)" \
+ LIB="$(LIB)" \
+ lib_LTLIBRARIES="$(lib_LTLIBRARIES)" \
+ CHECK_GLOBALS_REGEX=$(CHECK_GLOBALS_REGEX)
+
+dist_check_SCRIPTS = check-globals.sh
+
+TESTS = $(dist_check_SCRIPTS)