aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-05-26 08:25:00 +0300
committerMatias Elo <matias.elo@nokia.com>2021-05-26 08:25:00 +0300
commit0f7caa1ed38afcd78b23c3ee0d2ef94a8f980236 (patch)
tree686e44d7f78ec662d9a03ed8367135ee9bda218d /helper/Makefile.am
parentcb9db0fa8ca6dd0d58ffe6180affe43abe53956c (diff)
parent639f4d5831927a2e10670ebb8f36481a5db1093c (diff)
Merge tag 'v1.28.0.0' of https://github.com/OpenDataPlane/odp into odp-dpdk
Signed-off-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 15e968310..56fd5bd6b 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -83,3 +83,16 @@ __LIB__libodphelper_la_LIBADD = $(PTHREAD_LIBS)
__LIB__libodphelper_la_LIBADD += $(LIBCLI_LIBS)
lib_LTLIBRARIES = $(LIB)/libodphelper.la
+
+CHECK_GLOBALS_REGEX = " odph_"
+
+TESTS_ENVIRONMENT = \
+ LIBTOOL="$(LIBTOOL)" \
+ NM="$(NM)" \
+ LIB="$(LIB)" \
+ lib_LTLIBRARIES="$(lib_LTLIBRARIES)" \
+ CHECK_GLOBALS_REGEX=$(CHECK_GLOBALS_REGEX)
+
+dist_check_SCRIPTS = check-globals.sh
+
+TESTS = $(dist_check_SCRIPTS)