aboutsummaryrefslogtreecommitdiff
path: root/example/cli/Makefile.am
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-04-28 15:52:39 +0300
committerGitHub <noreply@github.com>2021-04-28 15:52:39 +0300
commit029cb31ef951664c12cfe61563a25f3ff6449e5a (patch)
treebb12bb9dcd04e8a1176a782b50a16a085c03963f /example/cli/Makefile.am
parentc3e252739b6c5812d11ac07ec7df687d927de36e (diff)
parent20eb6b4655671fbfb6fd41c7407762cd30f1cfc5 (diff)
Merge ODP v1.27.0.0v1.27.0.0_DPDK_19.11
Merge ODP linux-generic v1.27.0.0 into ODP-DPDK.
Diffstat (limited to 'example/cli/Makefile.am')
-rw-r--r--example/cli/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/example/cli/Makefile.am b/example/cli/Makefile.am
new file mode 100644
index 000000000..0e97a09ed
--- /dev/null
+++ b/example/cli/Makefile.am
@@ -0,0 +1,31 @@
+include $(top_srcdir)/example/Makefile.inc
+
+bin_PROGRAMS = odp_cli
+
+odp_cli_SOURCES = odp_cli.c
+
+if test_example
+TESTS = odp_cli_run.sh
+endif
+
+EXTRA_DIST = odp_cli_run.sh
+
+# If building out-of-tree, make check will not copy the scripts and data to the
+# $(builddir) assuming that all commands are run locally. However this prevents
+# running tests on a remote target using LOG_COMPILER.
+# So copy all script and data files explicitly here.
+all-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ if [ -e $(srcdir)/$$f ]; then \
+ mkdir -p $(builddir)/$$(dirname $$f); \
+ cp -f $(srcdir)/$$f $(builddir)/$$f; \
+ fi \
+ done \
+ fi
+clean-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ rm -f $(builddir)/$$f; \
+ done \
+ fi