aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMaxim Uvarov <maxim.uvarov@linaro.org>2015-08-31 14:04:24 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-08-31 18:06:46 +0300
commit2dfe5ebb8344245abbc52c188b84c4ae7781f911 (patch)
tree2e1c1893c2f39fbb2cafdc7ba8b6298b3f4956ce /debian
parent922f3ffa0cc0bf97c30698461f88d2c6fe0034fb (diff)
update version number from v1.2.0.0 to v1.3.0.0
Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog80
1 files changed, 80 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f7fdc3548..741ab7279 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,83 @@
+opendataplane (1.3.0.0-1) unstable; urgency=low
+ * API:
+ - codespell: correct spelling
+ - event: change to odp_event_type_t
+ - init: use const pointer types
+ - packet_io: added odp_pktio_param_t
+ - packet_io: added start and stop
+ - packet_io: change word instance to interface
+ - pktio: added output mode
+ - pktio: rename pktio_input_mode enum
+ - pool: add odp_pool_param_init prototype
+ - pool: standardize description for odp_pool_param_init routine
+ - queue: add odp_queue_param_init prototype
+ - queue: clarify odp_queue_context_set() documentation
+ - queue: rename queue context get/set for consistency
+ - sched: added ordered context lock
+ - sched: added release ordered
+ - sched: added schedule group create and destroy
+ - sched: added schedule prefetch
+ - sched: added worker group
+ - sched: clarified synchronization context
+ - sched: clarify usage of PRIO_DEFAULT
+ - sched: moved scheduler types into new file
+ - sched: removed GROUP_DEFAULT
+ - sched: removed SYNC_DEFAULT
+ - sched: schedule param
+ - schedule: fix comment typo
+ - spelling fixes
+ - style: init api: documentation clean up
+ * ODP docs:
+ - doc: implementers-guide: add validation description
+ - doc: publish contributing text
+ * ODP helper:
+ - fix installation path for includes
+ - linux: catch possible undefined
+ - test: chksum: catch errors in scan_ip
+ * test:
+ * validation:
+ - add test on unused retvals
+ - use _CU_TEST_INFO() macro
+ - system: fix uninitialised variable
+ - test odp_pktio_start and odp_pktio_stop
+ - fix build from tar source
+ - kill odp_generator
+ - removing current dir from -I
+ * performance:
+ - Makefile: add scripts to EXTRA_DIST
+ - l2fwd: fix race condition between thread init and stat counter
+ - l2fwd: capture test fails
+ - odp_pktio_perf: use real MAC addresses while packet creation
+ - odp_scheduling: remove redundant var inits
+ - use odp_pool_param_init routine
+ - use odp_queue_param_init routine
+ * general:
+ - Makefile.am: fix basename conflicts
+ - Makefile: add all arch to the tarball
+ - fix logic for calling pktio init and term functions
+ - install missing headers
+ - move default cpumask functions to separate file
+ - move openssl checks inside linux-generic
+ - move pthread checks inside linux-generic
+ - add pktio_start and pktio_stop
+ - pktio: add global init and term function for pktios
+ - pktio: always test loop interface
+ - pktio: handle segmented packet in socket mode
+ - pktio: remove basic socket implementation
+ - pktio: store errno correctly in setup
+ - pool: add odp_pool_type_t enum
+ - pool: implement odp_pool_param_init
+ - queue: implement odp_queue_param_init routine
+ - remove linux-generic makefile generation from common configure.ac
+ - schedule pktin_poll: account pktio stop state
+ - Makefile.am: fix aclocal warning when building from tarball
+ - m4: pthread: fix warning with Wextra
+ - scripts/git_hash: change repo to CUSTOM_STR
+ - scripts/git_hash: fix build from tar source
+ - scripts: Makefile: add odp_version.sh to the tarball
+
+ -- Maxim Uvarov <maxim.uvarov@linaro.org> Mon, 31 Aug 2015 14:02:57 +0300
+
opendataplane (1.2.0.0-1) unstable; urgency=low
* API:
- docs: doxygen grouping clean up and remove excess references to ODP