aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStanislaw Kardach <skardach@marvell.com>2020-06-19 19:04:23 +0200
committerPetri Savolainen <petri.savolainen@nokia.com>2020-07-01 12:55:03 +0300
commitdccd448572f9332157c9d915a8683282326349db (patch)
treef215f08c6047298e90e5ebd144b8063d82a75a8c /configure.ac
parent6970a0817fcb339a06bf6df632ca569687ed9440 (diff)
build: fix GCC 10 detection
GCC version may contain minor and patch version, therefore extract major version expecting that. Signed-off-by: Stanislaw Kardach <skardach@marvell.com> Reviewed-by: Janne Peltonen <janne.peltonen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 87d91d03c..6f9feed12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,7 +136,7 @@ ODP_CHECK_CFLAG([-Wno-error=address-of-packed-member])
# GCC 10 sometimes gets confused about object sizes and gives bogus warnings.
# Make the affected warnings generate only warnings, not errors.
AS_IF([test "$GCC" == yes],
- AS_IF([test `$CC -dumpversion` -ge 10],
+ AS_IF([test `$CC -dumpversion | cut -d '.' -f 1` -ge 10],
ODP_CHECK_CFLAG([-Wno-error=array-bounds])
ODP_CHECK_CFLAG([-Wno-error=stringop-overflow])
)