aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2023-07-07 09:14:58 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2023-07-12 12:30:54 +0300
commitc842aa496355bef0fcc7ca2248f0ce4576f9027d (patch)
tree63f5c399c1a75a34d1869093ce665c9cd1096dee /configure.ac
parent114321a5d89d965e99e68c0e3c07d98fcb3fd67f (diff)
api: increment ODP API version to 1.42.0
Increment API version number to reflect the following changes: Backward incompatible: - crypto: change 'bit_mode' cipher/auth capability flag to indicate whether bit mode is supported in addition to byte mode that is always supported - crypto: add 'cipher_range_in_bits' and 'auth_range_in_bits' session parameters Backward compatible: - barrier: add memory barriers odp_mb_sync(), odp_mb_sync_load(), and odp_mb_sync_store() - crypto: allow non-zero-length cipher and auth ranges for the null cipher and auth algorithms in the OOP operation type - dma: add 'uarea_persistence' pool capability - dma: add 'uarea_init' pool parameters 'init_fn' and 'args' - dma: move odp_dma_seg_t structure fields - event: add odp_event_types_multi() function - event: add odp_event_user_area_and_flag() function - init: add ODP_LOG_WARN log level to odp_log_level_t - packet: change odp_packet_user_flag() and odp_packet_vector_user_flag() documentations to specify that the return values are positive - pool: add 'uarea_persistence' pool capability - pool: add 'uarea_init' pool parameters 'init_fn' and 'args' - timer: add odp_timeout_from_event_multi() function - timer: clarify odp_timer_alloc() and odp_timer_restart() documentation Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ae9967c76..0b91c6981 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odp_version_generation], [1])
-m4_define([odp_version_major], [41])
-m4_define([odp_version_minor], [1])
+m4_define([odp_version_major], [42])
+m4_define([odp_version_minor], [0])
m4_define([odp_version_patch], [0])
m4_define([odp_version_api],