aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@nokia.com>2019-05-02 11:26:34 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2019-05-09 09:43:17 +0300
commit2e927d35cb368611d2684caee633dbff733cebe5 (patch)
tree0444a432702bd5d0a758421512a74b8a77cecac9 /configure.ac
parent9dced3ede96b81f883172bad827054bd796c13b4 (diff)
helper: add helper version defines
Added helper library version defines, so that application can track helper version independent of ODP API version. Added also function for easy print out of the versions number. Signed-off-by: Petri Savolainen <petri.savolainen@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Stanislaw Kardach <skardach@marvell.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 29ffef29e..fa8dcce79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.5])
##########################################################################
-# Set correct API version
+# ODP API version
##########################################################################
m4_define([odpapi_generation_version], [1])
m4_define([odpapi_major_version], [21])
@@ -16,6 +16,24 @@ ODP_VERSION_API_MAJOR=odpapi_major_version
AC_SUBST(ODP_VERSION_API_MAJOR)
ODP_VERSION_API_MINOR=odpapi_minor_version
AC_SUBST(ODP_VERSION_API_MINOR)
+
+##########################################################################
+# Helper library version
+##########################################################################
+m4_define([odph_version_generation], [1])
+m4_define([odph_version_major], [0])
+m4_define([odph_version_minor], [0])
+
+m4_define([odph_version],
+ [odph_version_generation.odph_version_major.odph_version_minor])
+
+ODPH_VERSION_GENERATION=odph_version_generation
+AC_SUBST(ODPH_VERSION_GENERATION)
+ODPH_VERSION_MAJOR=odph_version_major
+AC_SUBST(ODPH_VERSION_MAJOR)
+ODPH_VERSION_MINOR=odph_version_minor
+AC_SUBST(ODPH_VERSION_MINOR)
+
AM_INIT_AUTOMAKE([1.9 tar-pax subdir-objects foreign nostdinc -Wall -Werror])
AC_CONFIG_SRCDIR([include/odp/api/spec/init.h])
AM_CONFIG_HEADER([include/config.h])
@@ -360,6 +378,7 @@ AC_CONFIG_FILES([include/Makefile
include/odp/api/spec/version.h
include/odp/api/spec/deprecated.h])
+AC_CONFIG_FILES([helper/include/odp/helper/version.h])
##########################################################################
# distribute the changed variables among the Makefiles