aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLifang Zhang <lifang.zhang@nokia.com>2021-10-07 15:44:38 +0300
committerMatias Elo <matias.elo@nokia.com>2021-10-12 14:43:10 +0300
commit29ff9cd79290aa6eaf74c8fc957cde8aec84f9af (patch)
treeee3e0f3d7d8e25554cde4211457302787e79871b /configure.ac
parenta2a1063c80ab75643f9dcc03b4a28bdc50156e6c (diff)
configure.ac: break long lines
Break long lines into multiple ones to improve readability. Signed-off-by: Lifang Zhang <lifang.zhang@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 38 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e2a227cd2..c05cb4914 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,12 @@ AS_IF([test "$ac_cv_env_CFLAGS_set" = ""], [user_cflags=0], [user_cflags=1])
# Initialize automake
AM_INIT_AUTOMAKE([1.9 tar-pax subdir-objects foreign nostdinc -Wall -Werror])
AC_CONFIG_SRCDIR([include/odp/api/spec/init.h])
-AC_CONFIG_HEADERS([include/odp/autoheader_build.h include/odp/autoheader_external.h include/odp/autoheader_internal.h helper/include/odp/helper/autoheader_external.h])
+AC_CONFIG_HEADERS(m4_normalize([
+ include/odp/autoheader_build.h
+ include/odp/autoheader_external.h
+ include/odp/autoheader_internal.h
+ helper/include/odp/helper/autoheader_external.h
+]))
AC_USE_SYSTEM_EXTENSIONS
AC_SYS_LARGEFILE
@@ -89,11 +94,41 @@ PKG_PROG_PKG_CONFIG
dnl breaks cross-compilation and malloc(0) behaviour is not that important
dnl AC_FUNC_MALLOC
AC_FUNC_MMAP
-AC_CHECK_FUNCS([bzero clock_gettime gethostbyname getpagesize gettimeofday malloc memset munmap socket strchr strerror strrchr strstr strtoull])
+AC_CHECK_FUNCS(m4_normalize([
+ bzero
+ clock_gettime
+ gethostbyname
+ getpagesize
+ gettimeofday
+ malloc
+ memset
+ munmap
+ socket
+ strchr
+ strerror
+ strrchr
+ strstr
+ strtoull
+]))
# Checks for header files.
AC_HEADER_RESOLV
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h unistd.h])
+AC_CHECK_HEADERS(m4_normalize([
+ arpa/inet.h
+ fcntl.h
+ inttypes.h
+ limits.h
+ netdb.h
+ netinet/in.h
+ stddef.h
+ stdint.h
+ stdlib.h
+ string.h
+ sys/ioctl.h
+ sys/socket.h
+ sys/time.h
+ unistd.h
+]))
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL