aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2019-10-02 15:48:59 +0300
committerMatias Elo <matias.elo@nokia.com>2019-10-07 09:49:07 +0300
commit18abf931651e3f21bc858efc2f1df50f24821611 (patch)
tree5689fa043b8b899a44d444bfb31b5948acc85bb6 /configure.ac
parent60a830b9e000053caab24a0befb578551ba1766b (diff)
linux-gen: include only ODP defines in autogenerated header files
The config.h file has been split into three parts: autoheader_build.h: should NOT be included by ANY source file autoheader_external.h: can be included by any source file, including public headers autoheader_internal.h: can be included by any internal source file, but NOT by public headers autoheader_external.h and autoheader_internal.h are generated based on matching template files (*.in) and include only ODP defines. autoheader_build.h includes all build defines and should not be included by any source file. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 69474878d..e665c10c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,7 @@ AS_IF([test "$ac_cv_env_CFLAGS_set" = ""], [user_cflags=0], [user_cflags=1])
# Initialize automake
AM_INIT_AUTOMAKE([1.9 tar-pax subdir-objects foreign nostdinc -Wall -Werror])
AC_CONFIG_SRCDIR([include/odp/api/spec/init.h])
-AM_CONFIG_HEADER([include/odp/config.h])
+AM_CONFIG_HEADER([include/odp/autoheader_build.h include/odp/autoheader_external.h include/odp/autoheader_internal.h])
AC_USE_SYSTEM_EXTENSIONS
AC_SYS_LARGEFILE