aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStanislaw Kardach <skardach@marvell.com>2020-04-23 12:53:05 +0200
committerMatias Elo <matias.elo@nokia.com>2020-09-07 13:38:00 +0300
commit12016da75a670525195ec0c00fc5fdd0a58fc9f7 (patch)
tree989bd672782de637fea81a91802a0847fe84e7d9 /configure.ac
parent16576aa5e57e69075258cac0ef5e96be7d807c99 (diff)
build: move OpenSSL config to common config
Autoconf configuration for OpenSSL is required for the IPSec example as well as for linux-generic internals. Therefore any other platform added will by extension require this code if it wants to compile the IPSec example. Signed-off-by: Stanislaw Kardach <skardach@marvell.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 29e51e14a..5ae6a0fd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -291,6 +291,18 @@ then
fi
##########################################################################
+# Configure/disable usage of OpenSSL library
+##########################################################################
+AC_ARG_WITH([openssl],
+ [AS_HELP_STRING([--without-openssl],
+ [compile without OpenSSL (may result in disabled crypto and random support)])],
+ [],
+ [with_openssl=yes])
+AS_IF([test "$with_openssl" != "no"],
+ [ODP_OPENSSL])
+AM_CONDITIONAL([WITH_OPENSSL], [test x$with_openssl != xno])
+
+##########################################################################
# Include m4 files
##########################################################################
m4_include([./doc/m4/configure.m4])