aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStanislaw Kardach <skardach@marvell.com>2020-04-23 15:12:43 +0200
committerMatias Elo <matias.elo@nokia.com>2020-09-07 13:38:00 +0300
commit0243d8866e06a7c10112f40862646f2183b11948 (patch)
tree38eaad049bef882577d9914bf96fbfb528c4e0c5 /configure.ac
parenteba8f171cbabbdb5769a0c614b838cf3bb58627b (diff)
build: add ability to emit platform config state
Every platform may now add its own configure status by appending to PLAT_CFG_TEXT autoconf variable. Note that since it is an autoconf variable, it should be appended by AS_VAR_APPEND. Signed-off-by: Stanislaw Kardach <skardach@marvell.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5ae6a0fd8..c58407191 100644
--- a/configure.ac
+++ b/configure.ac
@@ -418,6 +418,10 @@ AC_SUBST([with_platform])
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=297726
PLAT_DEP_LIBS=
AC_SUBST([PLAT_DEP_LIBS])
+# Platforms should append to this variable to have their settings printed
+# at the end of the configure report.
+PLAT_CFG_TEXT="
+ Platform specific:"
AS_IF([test "${with_platform}" = "linux-generic"],
[m4_include([./platform/linux-generic/m4/configure.m4])],
@@ -519,8 +523,7 @@ AC_MSG_RESULT([
test_helper: ${test_helper}
test_example: ${test_example}
user_guides: ${user_guides}
- pcapng: ${have_pcapng}
- default_config_path: ${default_config_path}
+${PLAT_CFG_TEXT}
])
AS_IF([test "${with_openssl}" = "no"],