aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-11-30 16:34:26 +0200
committerPetri Savolainen <petri.savolainen@nokia.com>2021-12-08 09:52:13 +0200
commitd964432cc040aa911c2e289483313473e5c885be (patch)
tree83bfc820c3a6429382994346d741fc36657ac708 /configure.ac
parent5bcd3c3853fdd5aea88afa173451d85f4dad820a (diff)
configure: move openssl options under linux-gen platform
OpenSSL crypto and random implementations are platform specific, so move the configuration options under linux-genec platform. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 1aa5a85c3..0bd3a9296 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,37 +324,6 @@ then
fi
##########################################################################
-# Configure/disable usage of OpenSSL library
-##########################################################################
-AC_ARG_WITH([openssl],
- [AS_HELP_STRING([--without-openssl],
- [compile without OpenSSL (may result in disabled crypto and random support)]
- [[default=with]])],
- [],
- [with_openssl=yes])
-AS_IF([test "$with_openssl" != "no"],
- [ODP_OPENSSL
- have_openssl=1], [have_openssl=0])
-AM_CONDITIONAL([WITH_OPENSSL], [test x$with_openssl != xno])
-AC_DEFINE_UNQUOTED([_ODP_OPENSSL], [$have_openssl],
- [Define to 1 to enable OpenSSL support])
-
-have_openssl_rand=1
-AC_ARG_ENABLE([openssl-rand],
- [AS_HELP_STRING([--disable-openssl-rand],
- [Disable OpenSSL random data (use arch-specific instead)]
- [[default=enabled]])],
- [if test "x$enableval" = "xno"; then
- have_openssl_rand=0
- fi])
-
-AS_IF([test "$have_openssl" != "1"], [have_openssl_rand=0])
-AS_IF([test "$have_openssl_rand" = "1"], [openssl_rand=yes], [openssl_rand=no])
-
-AC_DEFINE_UNQUOTED([_ODP_OPENSSL_RAND], [$have_openssl_rand],
- [Define to 1 to enable OpenSSL support])
-
-##########################################################################
# Include m4 files
##########################################################################
m4_include([./doc/m4/configure.m4])
@@ -537,8 +506,6 @@ AC_MSG_RESULT([
includedir: ${includedir}
testdir: ${testdir}
WITH_ARCH: ${WITH_ARCH}
- with_openssl: ${with_openssl}
- openssl_rand: ${openssl_rand}
cc: ${CC}
cc version: ${CC_VERSION}
@@ -569,7 +536,3 @@ AC_MSG_RESULT([
user_guides: ${user_guides}
${PLAT_CFG_TEXT}
])
-
-AS_IF([test "${with_openssl}" = "no"],
- [AC_MSG_WARN([Strong cryptography is not available without OpenSSL])]
- )