aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2022-09-21 10:27:25 +0300
committerMatias Elo <matias.elo@nokia.com>2022-09-30 10:57:48 +0300
commitc93e0cfd212c0a3a36d3d22bd848c7146aad093d (patch)
treedfb3ef11be447f5d2066d95d4816ed3119a64ff9 /configure.ac
parent38233f05ee395d7b6569be274b0c2664b18283bb (diff)
api: increment ODP API version to 1.38.0.0
Increment API version number to reflect the following changes: Backward incompatible: - pool: change odp_pool_capability_t.pkt.max_uarea_size to state that the value of zero means user area is not supported - pool: specify that the default value of odp_pool_param_t.pkt.uarea_size is zero and implementation may round up the given value Backward compatible: - buffer: add odp_buffer_user_area() function which returns pointer to the user area - crypto: add experimental ZUC-256 support - packet: add odp_packet_vector_user_area() function which returns pointer to the user area - packet: add new user flag metadata to packets and packet vectors - pool: add user area size capability and parameter into buffer, timeout, and vector event pools - stash: add batch variants of all put/get functions and capabilities for maximum supported batch sizes - thread: clarify odp_thread_id() specification - timer: add odp_timeout_user_area() function which returns pointer to the user area Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e33fa1ee3..d184c7fbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odp_version_generation], [1])
-m4_define([odp_version_major], [37])
-m4_define([odp_version_minor], [2])
+m4_define([odp_version_major], [38])
+m4_define([odp_version_minor], [0])
m4_define([odp_version_patch], [0])
m4_define([odp_version_api],