aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2015-05-12 17:32:11 -0400
committerMike Holmes <mike.holmes@linaro.org>2015-05-27 08:38:25 -0400
commitee48c657b52d0f8dd8a11c18c62bce8920935c3e (patch)
treea43b3ec28406a3d82f2e0b2fc8578fcf33b65ae5 /configure.ac
parenta9cc0fc700a4a8b9589404a18136b01974ca4aa3 (diff)
test: helper: add process and thread tests
The helpers need to be tested independently from the ODP API, create a folder to contain helper tests, adding tests for process and thread creation. Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Christophe Milard <christophe.milard@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d20bad227..59e905795 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,6 +138,20 @@ AC_ARG_ENABLE([test-perf],
AM_CONDITIONAL([test_perf], [test x$test_perf = xyes ])
##########################################################################
+# Enable/disable test-helper
+##########################################################################
+test_helper=yes
+AC_ARG_ENABLE([test-helper],
+ [ --enable-test-helper run test in helper/test],
+ [if test "x$enableval" = "xyes"; then
+ test_helper=yes
+ fi])
+
+AM_CONDITIONAL([test_helper], [test x$test_helper = xyes ])
+
+##########################################################################
+
+##########################################################################
# Enable/disable test-cpp
##########################################################################
test_cpp=no
@@ -277,6 +291,8 @@ AC_CONFIG_FILES([Makefile
example/ipsec/Makefile
example/packet/Makefile
example/timer/Makefile
+ helper/Makefile
+ helper/test/Makefile
pkgconfig/libodp.pc
platform/Makefile
platform/linux-generic/Makefile
@@ -328,4 +344,5 @@ AC_MSG_RESULT([
test_vald: ${test_vald}
test_perf: ${test_perf}
test_cpp: ${test_cpp}
+ test_helper: ${test_helper}
])