aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZoltan Kiss <zoltan.kiss@linaro.org>2015-06-09 18:37:42 +0100
committerZoltan Kiss <zoltan.kiss@linaro.org>2015-06-09 18:37:42 +0100
commitdb2af0cf1c48278015ebfab2faa08a2c8617e9ef (patch)
tree194282b163a397de24e74e94a5d3b7e82f0136e1 /configure.ac
parentd369df66acc7c9d8d06653d81df337ff049af52c (diff)
parenta6d1ce8e83eb599e1ac67b7995d8738c6debe702 (diff)
Merge git://git.linaro.org/lng/odp
Interim merge to cherry-pick patches, and solve sync problem between the two repo.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 642125f86..150d12001 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,7 @@ AC_TYPE_UINT64_T
AX_VALGRIND_CHECK
##########################################################################
-# Which archetecture optimizations will we use
+# Which architecture optimizations will we use
##########################################################################
AS_CASE([$host],
[x86*], [ARCH=x86],
@@ -72,7 +72,7 @@ AC_ARG_WITH([platform],
[AS_HELP_STRING([--with-platform=platform],
[select platform to be used, default linux-dpdk])],
[],
- [with_platform=linux-dpdk
+ [with_platform=linux-generic
])
AC_SUBST([with_platform])
@@ -141,6 +141,20 @@ AC_ARG_ENABLE([test-perf],
AM_CONDITIONAL([test_perf], [test x$test_perf = xyes ])
##########################################################################
+# Enable/disable test-helper
+##########################################################################
+test_helper=yes
+AC_ARG_ENABLE([test-helper],
+ [ --enable-test-helper run test in helper/test],
+ [if test "x$enableval" = "xyes"; then
+ test_helper=yes
+ fi])
+
+AM_CONDITIONAL([test_helper], [test x$test_helper = xyes ])
+
+##########################################################################
+
+##########################################################################
# Enable/disable test-cpp
##########################################################################
test_cpp=no
@@ -280,10 +294,13 @@ AC_CONFIG_FILES([Makefile
example/ipsec/Makefile
example/packet/Makefile
example/timer/Makefile
+ helper/Makefile
+ helper/test/Makefile
pkgconfig/libodp.pc
platform/Makefile
platform/linux-generic/Makefile
platform/linux-dpdk/Makefile
+ scripts/Makefile
test/Makefile
test/api_test/Makefile
test/performance/Makefile
@@ -332,4 +349,5 @@ AC_MSG_RESULT([
test_vald: ${test_vald}
test_perf: ${test_perf}
test_cpp: ${test_cpp}
+ test_helper: ${test_helper}
])