aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2016-04-01 22:31:40 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-07 09:41:17 +0300
commitebf0bad7aaf6396c316eb28117f6c228eb527fd6 (patch)
tree1e0cf57483237e880c739fd0162f3474312f0ceb /configure.ac
parentd608a318f64b00de13b345065868b8d74ddde892 (diff)
configure: remove separate so_version file
Set versioning in configure.ac directly, folks familiar with autotools will expect it to be set there. Suggested-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Reviewed-by: Ricardo Salveti <ricardo.salveti@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 48a30be04..712d2414c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,12 @@ AC_SYS_LARGEFILE
AC_CONFIG_MACRO_DIR([m4])
AM_SILENT_RULES([yes])
+##########################################################################
+# Set correct platform library version
+##########################################################################
+ODP_LIBSO_VERSION=108:0:0
+AC_SUBST(ODP_LIBSO_VERSION)
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
@@ -61,10 +67,8 @@ AS_CASE([$host],
AC_SUBST([ARCH])
##########################################################################
-# Set correct platform library version
+# Set correct pkgconfig version
##########################################################################
-ODP_LIBSO_VERSION=$(cat ${srcdir}/.so_version)
-AC_SUBST(ODP_LIBSO_VERSION)
PKGCONFIG_VERSION=$(echo $VERSION | awk -F '.git' '{print $1}')
AC_SUBST(PKGCONFIG_VERSION)